Home >> Linux >> Mozilla To Drop Support For All NPAPI Plugins In Firefox 52 Except Flash

Mozilla To Drop Support For All NPAPI Plugins In Firefox 52 Except Flash

The Netscape Plugins API is “an ancient plugins infrastructure inherited from the old Netscape browser on which Mozilla built Firefox,” according to Bleeping Computer.
But now an anonymous reader writes: Starting March 7, when Mozilla is scheduled to release Firefox 52, all plugins built on the old NPAPI technology will stop working in Firefox, except for Flash, which Mozilla plans to support for a few more versions. This means technologies such as Java, Silverlight, and various audio and video codecs won’t work on Firefox. These plugins once helped the web move forward, but as time advanced, the Internet’s standards groups developed standalone Web APIs and alternative technologies to support most of these features without the need of special plugins. The old NPAPI plugins will continue to work in the Firefox ESR (Extended Support Release) 52, but will eventually be deprecated in ESR 53. A series of hacks are available that will allow Firefox users to continue using old NPAPI plugins past Firefox 52, by switching the update channel from Firefox Stable to Firefox ESR.


Share on Google+

Read more of this story at Slashdot.

Leave a Reply

Your email address will not be published. Required fields are marked *

*

*